Home » DataWarrior » Installation Issues » How to run datawarrior on Linux
How to run datawarrior on Linux [message #590] Mon, 08 July 2019 23:16 Go to next message is currently offline
Messages: 1
Registered: July 2019
Junior Member
I have installed datawarrior on my Centos 7 along with all necessary Java support. It is not clear to me how to run/start this tool before use. I tried with "module load datawarrior", but nothing come up to use.I have file test.dwar but it is not recognized by datawarrior.
Re: How to run datawarrior on Linux [message #592 is a reply to message #590] Tue, 09 July 2019 13:31 Go to previous message
thomas is currently offline  thomas
Messages: 523
Registered: June 2014
Senior Member
I just tried to install DataWarrior on Centos7 using the current datawarrior for Linux installer v5.0.0.
First I confoirmed that Java is installed by typing 'java -version'. The output was:
openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-b04)
OpenJDK 64-Bit Server VM (build 25.212-b04, mixed mode)

I unpacked the datawarrior500_linux.tar.gz, opened a terminal, used 'cd' to navigate into the unpacked folder 'datawarrior_linux'. Then I typed:
chmod 755

to install datawarrior with superuser privileges.
After that I could start DataWarrior from the Applications/Office menu:

I also could open a test.dwar file with a double click. Can you verify that Java is installed properly with 'java -version'? If yes, then can you check, whether the /opt/datawarrior folder exists and whether you can start datawarrior from a terminal with '/opt/datawarrior/datawarrior'?


[Updated on: Tue, 09 July 2019 13:32]

Report message to a moderator

Previous Topic: Downloading Datawarrior - Dropbox issue ?
Next Topic: Datawarrior icons?
Goto Forum:

Current Time: Sun Aug 07 17:55:48 CEST 2022

Total time taken to generate the page: 0.01656 seconds