openmolecules.org

 
Home » DataWarrior » Installation Issues » Datawarrior not starting on manjaro (execvp error upon starting datawarrior after normal looking install process)
Datawarrior not starting on manjaro [message #1955] Wed, 12 July 2023 11:33 Go to next message
HeadBanger is currently offline  HeadBanger
Messages: 3
Registered: July 2023
Junior Member
I am running manjaro 6.4.2-3 KDE plasma 5.27.6-1 with openjdk version "20.0.1" 2023-04-18.
After downloading the tar_gz and following the steps in the readme.txt I get the following errorcode upon launching datawarrior

execvp: Exec format error

unfortunately the error message does not give more than that.
Re: Datawarrior not starting on manjaro [message #1956 is a reply to message #1955] Wed, 12 July 2023 15:21 Go to previous messageGo to next message
thomas is currently offline  thomas
Messages: 674
Registered: June 2014
Senior Member
I don't have Manjaro and cannot try, but a Google search revealed that sometimes you error appears on KDE in Manjaro, when scripts expect the bash, because the default is zsh. Can you add '#!/bin/sh' or '#!/bin/bash' (without single quotes) as a first line to your '/opt/datawarrior/datawarrior' script and try again?
Re: Datawarrior not starting on manjaro [message #1958 is a reply to message #1956] Thu, 13 July 2023 09:04 Go to previous message
HeadBanger is currently offline  HeadBanger
Messages: 3
Registered: July 2023
Junior Member
Both '#!/bin/sh' and '#!/bin/bash' (without the single quotes) work as a solution.

Thank you for the reply. Somehow it did not occur to also search for the error and plasma.
Previous Topic: Problem opening the program on my MacBook
Next Topic: Windows 11 issue
Goto Forum:
  


Current Time: Thu Jun 13 09:52:49 CEST 2024

Total time taken to generate the page: 0.04351 seconds