openmolecules.org

 
Home » DataWarrior » Bug Reports » unable to open files when username contains umlaut (File not found)
unable to open files when username contains umlaut [message #1498] Wed, 09 February 2022 09:58 Go to next message
picoalex is currently offline  picoalex
Messages: 1
Registered: February 2022
Junior Member
Hi everybody,

when I try to open an .sdf file in Windows by clicking on it (with a working version of DataWarrior) installed, I get an error message saying 'File not found'. In the path displayed, the Umlaut in my name is not reproduced, instead there is a question mark.
When I try to open the same file in DataWarrior, by File-->Open, etc everything works nicely.

This is why I assume it is the 'non-standard' letter in my name, that makes the file path incompatible with DataWarrior.

Any suggestions?

Best wishes
Alex
Re: unable to open files when username contains umlaut [message #1507 is a reply to message #1498] Fri, 11 February 2022 17:55 Go to previous message
thomas is currently offline  thomas
Messages: 537
Registered: June 2014
Senior Member
Thank you for reporting. This is indeed due to the Umlaut. There seems to be a file name encoding issue somewhere in the C++ code that launches DataWarrior. The problem does not occur on Linux or Macintosh. For the time being, the only workaround is to avoid non-standard characters in files names.
Previous Topic: Column groupings not carried over in template
Next Topic: text export from DW with one tab more than needed
Goto Forum:
  


Current Time: Sun Sep 25 12:53:06 CEST 2022

Total time taken to generate the page: 0.01650 seconds