openmolecules.org

 
Home » DataWarrior » Bug Reports » nasty functions not activated in 4.4.4 (search for nasty functions)
nasty functions not activated in 4.4.4 [message #222] Sun, 05 February 2017 14:16 Go to next message
dataviz is currently offline  dataviz
Messages: 4
Registered: November 2016
Junior Member
Hello
it looks in version 4.4.4 that the search for nasty functions is not activated. The message seen in the column is: initialization error
many thanks
Re: nasty functions not activated in 4.4.4 [message #244 is a reply to message #222] Fri, 17 March 2017 10:09 Go to previous messageGo to next message
arofab is currently offline  arofab
Messages: 2
Registered: March 2017
Junior Member
Hello,
I can confirm that "Nasty Functions" compound properties processing also fails in newest 4.5.1 version.
It stopped working since 4.4.4 version (in version 4.4.3 it worked).

Looking at the source code, the error seems to be related to the "twice activated DB" function. By commenting out the corresponding line in com.actelion.research.chem.NastyFunctionDetector class, the calculation succeeds (obviously excluding "twice activated DB" detection).
Re: nasty functions not activated in 4.4.4 [message #247 is a reply to message #244] Tue, 21 March 2017 20:43 Go to previous message
thomas is currently offline  thomas
Messages: 151
Registered: June 2014
Senior Member
Dear dataviz and arofab,

sorry, I notized your first message to late for version 4.5.1. In today's update 4.5.2 this issue is fixed.

Thanks for reporting,

Thomas
Previous Topic: "PathFp" fingerpring bug?
Next Topic: Name2Structure-Piperylene
Goto Forum:
  


Current Time: Thu Sep 20 09:09:17 CEST 2018

Total time taken to generate the page: 0.00533 seconds