openmolecules.org

 
Home » DataWarrior » Bug Reports » Structures not visible on 2D-axis
Structures not visible on 2D-axis [message #741] Fri, 27 December 2019 04:57 Go to next message
amorrison
Messages: 16
Registered: March 2016
Junior Member
Hi,
For 2D-graphical views, if I select a structure column (say from a r-grp decomposition), the structures no longer show on the axis. If I select the same r-group column in a 3d-view the r-groups show correctly.
Thanks,
Angus
Re: Structures not visible on 2D-axis [message #744 is a reply to message #741] Sun, 29 December 2019 15:05 Go to previous messageGo to next message
thomas is currently offline  thomas
Messages: 341
Registered: June 2014
Senior Member
Hi Angus,
I assume that this was a bug in an earlier version. You may check in the current pre-release, which is available as zip archive containing some files that replace older ones in the installation folder of the official 5.0.0 version. You may download the patch files from openmolecules.org/datawarrior/dw500win.zip (Windows) or openmolecules.org/datawarrior/dw500x.zip (Linux and OSX).
Thomas
Re: Structures not visible on 2D-axis [message #747 is a reply to message #744] Mon, 30 December 2019 07:19 Go to previous messageGo to next message
amorrison
Messages: 16
Registered: March 2016
Junior Member
Thanks Thomas, I've looked at my file again in more detail and noticed something odd. If the view is small, I can see the r-grps (attached image rgrp_minimised) but only the vertical lines of the grid (view set to show full grid). If I maximise this window the r-grps disappear and I lose the whole grid (rgrp_maximised). I've included an example dwar file from ChemBL where this behaviour occurs with R5 on the x-axis. Any thoughts how to deal with this?
Thanks,
Angus
Re: Structures not visible on 2D-axis [message #748 is a reply to message #747] Tue, 31 December 2019 18:33 Go to previous messageGo to next message
thomas is currently offline  thomas
Messages: 341
Registered: June 2014
Senior Member
Angus, thank you very much for posting files and reproducibly showing the issue. I have updated the logic when showing structures on axes on the 2D-view and hopefully fixed the issue. The dw500 zip files are updated.
Re: Structures not visible on 2D-axis [message #749 is a reply to message #748] Fri, 03 January 2020 09:21 Go to previous message
amorrison
Messages: 16
Registered: March 2016
Junior Member
Thanks Thomas, very much appreciated.
Angus
Previous Topic: Conformer Generation - Uncaught Exception
Next Topic: Enumerate Combinatorial Library - Uncaught Exception
Goto Forum:
  


Current Time: Thu Aug 06 12:51:05 CEST 2020

Total time taken to generate the page: 0.00741 seconds