openmolecules.org

 
Home » DataWarrior » Installation Issues » installation_linux
installation_linux [message #323] Fri, 13 April 2018 22:08 Go to next message
khom
Messages: 4
Registered: April 2018
Junior Member
I installed datawarrior 472. I tried to launch it with the desktop launcher and it failed. I then tried "/opt/datawarrior/datawarrior and got these messages. I am using java jre 1.7. Thank you for looking into this. Kellie

swt58:~/datawarrior_linux% /opt/datawarrior/datawarrior
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/actelion/research/datawarrior/DataWarriorLinux : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:792)
at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308 )
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper. java:482)
Re: installation_linux [message #324 is a reply to message #323] Mon, 16 April 2018 20:02 Go to previous message
thomas is currently offline  thomas
Messages: 151
Registered: June 2014
Senior Member
Since version 4.7.0 DataWarrior needs Java 1.8 or higher. This is because since then the program includes a new 3D-molecule viewer used as conformer viewer, which is based on JavaFX. And JavaFX came with Java 1.8. I recommend to use the newest Java 1.8 runtime, which currently is 8u161.

Sorry for the inconvenience,

Thomas
Previous Topic: problem with Java detection
Next Topic: problems about downloading datawarrior for windows
Goto Forum:
  


Current Time: Thu Sep 20 17:06:40 CEST 2018

Total time taken to generate the page: 0.00560 seconds