openmolecules.org

 
Home » DataWarrior » Installation Issues » Can't run DataWarrior on Windows 7 Pro
Can't run DataWarrior on Windows 7 Pro [message #280] Fri, 02 June 2017 16:03 Go to next message
kevinc is currently offline  kevinc
Messages: 1
Registered: June 2017
Junior Member
Hello,

I am having trouble running DataWarrior on Windows 7 Professional. When I run the executable, this fatal error pops up:

index.php?t=getfile&id=26&private=0

I read this thread (DataWarrior on window7 Pro) and I have tried freeing at least 1.2 GB of RAM before running DataWarrior again. This worked for one of my computers, but not for others.

I have checked my Java version, which is 32-bit Version 7 Update 80.

index.php?t=getfile&id=27&private=0

I have tried running both the 32-bit and 64-bit versions of DataWarrior with at least 1.2 GB of RAM free, but was unsuccessful.

Please advise.

Thanks,
Kevin
Re: Can't run DataWarrior on Windows 7 Pro [message #284 is a reply to message #280] Fri, 02 June 2017 23:03 Go to previous message
thomas is currently offline  thomas
Messages: 151
Registered: June 2014
Senior Member
Hi Kevin,

to me this looks like a memory problem. On Windows DataWarrior 32-bit requires a free block of 1.2 GB memory to start. I assume that even if your system claims you have 1.2 GB or more of free memory, this memory may be fragmented that it cannot be used. You may try to starting DataWarrior just after reeboot. Or, which may not an option for you, I recommend using Linux (e.g. Centos or Ubuntu) for old (and new) computers, because Linux uses resources more efficiently, typically runs faster and more stable and definitely causes less trouble with DataWarrior. You could easily finetune the amount of memory according to needs and availability.

Best wishes, Thomas
Previous Topic: Installation on Windows 10
Next Topic: Browser Problem
Goto Forum:
  


Current Time: Thu Sep 20 16:45:01 CEST 2018

Total time taken to generate the page: 0.00488 seconds