Home » DataWarrior » Installation Issues » Installation on Windows 10 (Issues when installing Datawarrior on Windows10)
Installation on Windows 10 [message #279] Wed, 31 May 2017 15:17 Go to next message
michaeldeligny is currently offline  michaeldeligny
Messages: 1
Registered: May 2017
Junior Member
Dear all,

I'm trying to install Datawarrior on my new laptop with windows 10, but get error message such:
'could not find Java 2 Runtime Environment'
I'm working with 64 bits machine, and indeed on the well documented webpage of openmolecules I noticed that installation on such a machine might be difficult.
I tried to install the 32 bits version but without success
I tried to install a Java update but without success.

Does someone has an idea ?
thank you very much for your help,
Re: Installation on Windows 10 [message #283 is a reply to message #279] Fri, 02 June 2017 22:49 Go to previous message
thomas is currently offline  thomas
Messages: 179
Registered: June 2014
Senior Member
Dear Michael,

this looks like the JRE is not properly installed. What do you get, if you open a terminal and type 'java -version'?
This should tell you, whether the JRE is available and whether it is 32-bit or 64-bit. (see installation issues description).
I get this:

java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

If you don't get '64-bit' somewhere, then it is 32 bit.

Best wishes, Thomas
Previous Topic: NullPointerException starting DW 4.5.1 on MacOS
Next Topic: Can't run DataWarrior on Windows 7 Pro
Goto Forum:

Current Time: Sat Feb 23 15:28:53 CET 2019

Total time taken to generate the page: 0.00346 seconds