openmolecules.org

 
Home » DataWarrior » Bug Reports » problem in running DataWarrior on MacBook Pro (MacBook pro blocks DataWarrior from running)
problem in running DataWarrior on MacBook Pro [message #1113] Sun, 08 November 2020 00:51 Go to next message
ZPei is currently offline  ZPei
Messages: 2
Registered: November 2020
Junior Member
I have been using DataWarrior on my PC for years without any major issue. I purchased a MacBook Pro recently, downloaded DataWarrior Mac version. But my Mac won't allow it to run. Error message says"DataWarrior can not be opened because the developer can not be verified. MacOS cannot verify that this app is free from malware". The only two options are either Delete the program or Cancel. My Mac run of MacOS Catalina v10.15.7. I called Apple tech support. So far they don't know how to solve it and the problem is being escalated to Apple Engineer. Does anyone know how to solve it. Thanks a lot. -ZP
Re: problem in running DataWarrior on MacBook Pro [message #1114 is a reply to message #1113] Sun, 08 November 2020 13:31 Go to previous messageGo to next message
thomas is currently offline  thomas
Messages: 384
Registered: June 2014
Senior Member
I made a Google search and found the following three solutions (which I cannot verify, because my Mac still runs High Sierra):

After you see the dialog box with Move to trash and Cancel:
Click Cancel
Open up System Preferences
Go to Security and Privacy -> General
There will be a message about the program that was blocked, with the option to Open Anyway
Source: this Apple support page (See section How to open an app that hasn't been notarized or is from an unidentified developer)

Hold the Control key and click on the app icon to open DataWarrior...

Type in a terminal window: xattr -d com.apple.quarantine /Applications/DataWarrior.app
Re: problem in running DataWarrior on MacBook Pro [message #1117 is a reply to message #1114] Tue, 10 November 2020 22:14 Go to previous message
ZPei is currently offline  ZPei
Messages: 2
Registered: November 2020
Junior Member
Your first suggestion worked (surprising that the Apple technical support people did not know this trick). Thank you so much, Thomas. You are a life saver!-Z
Previous Topic: 3D structure display is lost after hovering over certain structures
Next Topic: Problem running in Windows after windows update
Goto Forum:
  


Current Time: Thu Dec 03 20:51:54 CET 2020

Total time taken to generate the page: 0.00785 seconds