openmolecules.org

 
Home » DataWarrior » Bug Reports » 3D structure display is lost after hovering over certain structures (3D structure display anomaly)
3D structure display is lost after hovering over certain structures [message #1097] Mon, 26 October 2020 19:36 Go to next message
plkx is currently offline  plkx
Messages: 1
Registered: January 2020
Junior Member
Hello,

In either a DWAR or SDF file with 3D structures, the display window goes blank after certain structures are selected, or the mouse pointer is hovered over a row of the same (certain) structures.

Subsequently, 3D structures are not rendered for any other structures.

If the file is reopened (with or without quitting DataWarrior), 3D structure display returns, until the effect of a "deactivating structure" returns (e.g. by simply moving the mouse across the structure table pane).

The attached file contains examples of structures rendered properly, and those that deactivate 3D structure display. Methane, water, hydrogen sulfide, ammonia, and hydrogen halides cause the problem.

The file is not altered during the course of these glitches.

Best Regards,

Paul
  • Attachment: Tests.dwar
    (Size: 5.74KB, Downloaded 16 times)
Re: 3D structure display is lost after hovering over certain structures [message #1100 is a reply to message #1097] Tue, 27 October 2020 12:49 Go to previous messageGo to next message
thomas is currently offline  thomas
Messages: 384
Registered: June 2014
Senior Member
Hello Paul,

thank you for that clear report and the sample file. With that I could quickly find the problem and fix it.
The issue was the following: The 3D-coordinate encoding includes a value for the 'average bond length' to properly scale
a molecule after decoding and assigning relative atom coordinates. In a special case, where hydrogen coordinates
are included in the encoding, the average bond length was still calculated from non-hydrogen atoms only, which failed
in molecules that have no bonds between non-hydrogen as HI. For these molecules H-I distance are still not correct, if
3D-coordinates are not freshly calculated. But they are displayed correctly now and don't crash the 3D-viewer.

The bug is fixed in todays update of DataWarrior's development version.

Thomas
Re: 3D structure display is lost after hovering over certain structures [message #1102 is a reply to message #1100] Tue, 27 October 2020 17:41 Go to previous message
Paul is currently offline  Paul
Messages: 8
Registered: May 2019
Location: United States
Junior Member
Thank you, for providing the nice tool, and for such a quick fix.

Best Regards,

Paul
Previous Topic: Faulty SDF import
Next Topic: problem in running DataWarrior on MacBook Pro
Goto Forum:
  


Current Time: Thu Dec 03 20:31:56 CET 2020

Total time taken to generate the page: 0.00719 seconds